Cannot Open Layer2CloudConnectorBackendService Service on Computer
Error Example:
This error usually appears on startup in MMC for version 7.8+.
Cannot open Layer2CloudConnectorBackendService service on computer '.'.
Cause:
The most common cause is that the user starting the application does not have appropriate or elevated permissions. This may also be caused by installation issues - two versions installed or corrupted/incomplete installation.
Resolution/Workaround:
Please try the following steps:
- Start the application by right-clicking the "Start Cloud Connector Manager" in the start menu and select "Run as Administrator". This usually has enough permissions to start the Layer2CloudConnectorBackendService, which the app tries to start when first opened. If this works, you can go to the shortcut for "Start Cloud Connector Manager" and permanently set it to run as administrator in the properties for the shortcut.
- If the above doesn't work, try to start the Layer2CloudConnectorBackendService manually from the Services tool (or Task Manager).
- If this also fails to work and the service won't start for this error (or others), try to uninstall and re-install the Cloud Connector.
In case the error still persists, please submit a support request.